package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\b(?:i\s+)?(?:have\s+)?)(?:had|faced)\s+((?:the\s+)?same\s+(?:problem|question|issue|here))(*SKIP)(*F)|(?1)(?2)`)
var str = `having the same issue
facing the same problem
have the same question
I am getting the same issue
I see the same issue
I have same issue
I had the same issue
have had the same question
I faced the same issue`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}