import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(.*?)\\s+\\(([^)]+)\\):\\s*(.*?)(?:\\n\\n|\\Z)";
final String string = "\n"
+ "Peter (08:16): \n"
+ "Hi \n"
+ "What's up? \n"
+ ";-D\n\n"
+ "Anji Juo (09:13): \n"
+ "Hey, I'm using WhatsApp!\n\n"
+ "Peter (11:17):\n"
+ "Could you please tell me where is the feedback?\n\n"
+ "Anji Juo (19:13): \n"
+ "I don't know where it is. \n\n"
+ "Anji Juo (19:14): \n"
+ "Do you by any chance know where I can catch a taxi ?\n"
+ "🙏🙏🙏";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}