# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*?\"ENGLISH\")[^\"]*\".*(*SKIP)(*F)|(\"\")([^<>]*?)(\"\")(?=(?:[^>]*?(?:<|$)))"
test_str = (",\"FRENCH\",\"11.03.2022 13:36\",\"DocumentType.APPROVAL_AV\",\"Approbation de la personne responsable du marché (\"\"RdM\"\")\"\n"
",\"SPANISH\",\"11.03.2022 13:36\",\"DocumentType.APPROVAL_AV\",\"Aprobación del o de la responsable de la orden\"\n"
",\"ENGLISH\",\"11.03.2022 13:36\",\"DocumentType.ARGE_DECLARATION\",\"Declaration of the consortium (\"\"ARGE\"\")\"\n"
",\"FRENCH\",\"11.03.2022 13:36\",\"DocumentType.ARGE_DECLARATION\",\"Déclaration du groupement\"\n"
",\"SPANISH\",\"11.03.2022 13:36\",\"DocumentType.ARGE_DECLARATION\",\"Declaración del consorcio (en Alemania “ARGE”)\"\n"
",\"ENGLISH\",\"11.03.2022 13:54\",\"appHelpSignpostText\",\"If you have any technical issues, please do not hesitate to contact us personally through the following channels:<br /><br /><a href=\"\"https://test.com/\"\" target=\"\"_blank\"\">{{downloadIcon}}Guide</a> to help you enter your request.\"\n"
",\"FRENCH\",\"11.03.2022 13:54\",\"appHelpSignpostText\",\"Si vous rencontrez des difficultés techniques, n’hésitez pas à nous contacter personnellement via les canaux suivants : <br /><br /><a href=\"\"https://test.com/\"\" target=\"\"_blank\"\">{{downloadIcon}}Guide</a>, pour vous aider à saisir votre demande.\"\n"
",\"SPANISH\",\"11.03.2022 13:54\",\"appHelpSignpostText\",\"Si tiene dificultades técnicas, no dude en ponerse personalmente en contacto con nosotros o nosotras a través de los siguientes canales:<br /><br /><a href=\"\"https://test.com/\"\" target=\"\"_blank\"\">{{downloadIcon}}Guía</a>, que le servirá de ayuda para introducir su solicitud.\"\n"
",\"ENGLISH\",\"11.03.2022 13:36\",\"appraisalAndConsultingRadio\",\"Consulting contracts for <b>Test Service (TeS)</b>\"\n"
",\"FRENCH\",\"11.03.2022 13:36\",\"appraisalAndConsultingRadio\",\"Contrats de conseil pour <b>Test Service (TeS)</b>\"\n"
",\"ENGLISH\",\"11.03.2022 13:36\",\"argeRadio\",\"Consortium (called \"\"Arge\"\" in German)\"\n"
",\"FRENCH\",\"11.03.2022 13:36\",\"argeRadio\",\"Groupement momentané d’entreprises (groupement)\"\n"
",\"SPANISH\",\"11.03.2022 13:36\",\"appraisalAndConsultingRadio\",\"Contratos de asesoramiento para <b>Test (Tst)</b>\"\n"
",\"ENGLISH\",\"11.03.2022 13:54\", \"sustainabilitySignpostText\",\"The goal of sustainable management is to ensure that our earth is worth living on for future generations.<br /><br />More about GIZ’s sustainability activities can be found in the IDA communities <a href=\"\"https://test.com/\"\" target=\"\"_blank\"\">{{purIcon}}Corporate Sustainability\"\"</a> (more general) or <a href=\"\"https://test.com/\"\" target=\"\"_blank\"\">{{purIcon}}Sustainable Procurement</a> (especially for procurement). There you will find extensive information and handouts to help you make our planet a little more climate-friendly.<br /><br />And this begins not least in procurement.\"\n"
",\"ENGLISH\",\"11.03.2022 13:54\",\"biddersCountryOfOriginSignpost\",\"<table class=\"\"table\"\">\n"
" <tr>\n"
" <th>\"\"Bidders\"\" come from ...</th>\n"
" <th>Then I select ...</th>\n"
" <th>Explanation</th>\n"
" </tr>\n"
" <tr>\n"
",\"ENGLISH\",\"11.03.2022 13:36\",\"optionalDocumentTypeHelper\",\"Please give us a (brief) indication of what the additional document or file is about, for example \"\"Original contract 8126...\"\", \"\" Proof of ...\"\" or \"\"Approval of ...\"\". This will help us to classify and allocate them.\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.