# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?sx)([ァ-ヺ])(?=.*:\1=(.))/$2/gm;t' <<< "ァ ア ィ イ ゥ ウ ェ エ ォ オ カ ガ キ ギ ク グ ケ ゲ コ ゴ サ ザ シ ジ ス ズ セ ゼ ソ ゾ タ ダ チ ヂ ッ ツ ヅ テ デ ト ド ナ ニ ヌ ネ ノ ハ バ パ ヒ ビ ピ フ ブ プ ヘ ベ ペ ホ ボ ポ マ ミ ム メ モ ャ ヤ ュ ユ ョ ヨ ラ リ ル レ ロ ヮ ワ ヰ ヱ ヲ ン ヴ ヵ ヶ ヷ ヸ ヹ ヺ
Dictionary:ァ=ぁ:ア=あ:ィ=ぃ:イ=い:ゥ=ぅ:ウ=う:ェ=ぇ:エ=え:ォ=ぉ:オ=お:カ=か:ガ=が:キ=き:ギ=ぎ:ク=く:グ=ぐ:ケ=け:ゲ=げ:コ=こ:ゴ=ご:サ=さ:ザ=ざ:シ=し:ジ=じ:ス=す:ズ=ず:セ=せ:ゼ=ぜ:ソ=そ:ゾ=ぞ:タ=た:ダ=だ:チ=ち:ヂ=ぢ:ッ=っ:ツ=つ:ヅ=づ:テ=て:デ=で:ト=と:ド=ど:ナ=な:ニ=に:ヌ=ぬ:ネ=ね:ノ=の:ハ=は:バ=ば:パ=ぱ:ヒ=ひ:ビ=び:ピ=ぴ:フ=ふ:ブ=ぶ:プ=ぷ:ヘ=へ:ベ=べ:ペ=ぺ:ホ=ほ:ボ=ぼ:ポ=ぽ:マ=ま:ミ=み:ム=む:メ=め:モ=も:ャ=ゃ:ヤ=や:ュ=ゅ:ユ=ゆ:ョ=ょ:ヨ=よ:ラ=ら:リ=り:ル=る:レ=れ:ロ=ろ:ヮ=ゎ:ワ=わ:ヰ=ゐ:ヱ=ゑ:ヲ=を:ン=ん:ヴ=ゔ:ヵ=ヵ:ヶ=ヶ:ヷ=わ゙:ヸ=ゐ゙:ヹ=ゑ゙:ヺ=ヺ"