using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@\K(?:outlook|hotmail)(?=\.)";
string input = @"qwe@to-outlook.com
qwe@hotmail.com
qwe@gmail.com
qwe@outlook.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}