use strict;
my $str = 'BUILD THE ULTIMATE BRAWLER
Design your ultimate LEGO Minifigure hero with unique style, strategy and personality. A cactus with an attitude? A scrappy janitor ninja who happens to have fighting chickens? A sledgehammer-swinging clown with a few scores to settle? Sure! Build the ultimate brawler and level them up with unlockable content!
BATTLE THROUGH EPIC LEGO THEMES
From the swashbuckling shores of Barracuda Bay, to the waterlogged caverns of Ninjago® Seabound, to a dusty wild west saloon and the mythical Monkie Kid jungle, all of your favorite LEGO themes are brawlable! Collect unlockable minifigs, power-ups, and emotes along the way.
CROSS-PLAY WITH FRIENDS ACROSS PLATFORMS
Team up and brawl 4v4, party with friends, or play a battle royale-style game mode where it’s “every-player-for-themself”. With multiple game modes, levels have unique challenges and win conditions.';
my $regex = qr/([A-Z-]+(?: [A-Z]+)+(\r\n|\r|\n))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}