# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<![^\s\[,:.\/-])\b(?:1\d{3}|200[0123]|\d0)(?:'?s)?\b(?![^\s\],:.\/-])"
test_str = ("I need it to catch a date between 1000 and 2003 in these forms:\n"
"1975\n"
"1970s\n"
"1970's\n"
"1970S\n"
"1970'S\n"
"70s\n"
"70's\n"
"70S\n"
"70'S\n\n"
"I also need it to catch certain characters on either side of the date, including\n"
"dashes\n"
"-1973-\n"
"brackets\n"
"[1973]\n"
"commas\n"
",1973,\n"
"colons\n"
":1973:\n"
"periods\n"
".1973.\n"
"slashes\n"
"/1973/\n\n"
" - some on both sides, some on only one.\n"
"/1973\n"
"or\n"
"1973/\n\n"
"My problem is that the expression is catching other characers on either side of the date as well - +1975 gets through, for instance, as does 1970s& - letters and numbers on either side do not get through, however. I'm confused.\n\n"
"I think I might need some sort of limit on either side before I can state the exceptions, I'm not sure what that would look like - some kind of look back? Any help would be appreciated.")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.