use strict;
my $str = ' 70 02 [95386.467810]= 50 MiB 28414 (1806 ms in 2 ms) in 5 ms 2.74GHz 434MHz 90kHz 23Hz 1.7k 2
ul 07 [2484867] 41666 KiB/s 29107 [17755556] 0s [ | 2.74 GHz 434 MHz 90 KHz 45 kHz 23 Hz [143M
8317 (-70831 us) 10023ms ()-> 10022ms ( (37.9 kHz e) 0.389978] pci 4ns 1.4M 9986 [100k Sep-22]
468G 163G 282G 3 511M 5.3M 506M 5.5T 4.3T 1.3T 1.2T 890M 236G -l 1.1T 17G ) 3.4T c 1.1T 1.7T cinema 15G software 446G software 5.5T total 29k x 4 4.1k 23-Sr 4.1k 2 r 4.1k 1 4.1k :38 5 ter 4.1k r 4.1k st
23-Feb "2022-09-21T00:49:08.191147376+03:00"p4*[m 2% /boot/efi
@ 192.168.1.2 :/mnt/6Sep (0) g 02:45:46 done 600 601 605 628 +h
00:48:22 [0m 0312./05 III (2020-2021) 1';
my $regex = qr/(?<=[\s\b()-])(\d+)(\.\d+)?(?=\s?[A-Za-z]?)((\s?[kmgtpun])?(i?b/?s?|s|hz)?)(?=[]\s\b()[]|$)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}