$re = '/[a-z]+(?=\.mp3$)/m';
$str = 'abc/xyz/foo/bar/foobar.mp3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);