$re = '/\.\w+\.html$(*SKIP)(*F)|\.html$/m';
$str = 'file.php.html
file.html
file.zip.html
45785412@@@name.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);