package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mx)^
(?:[ab]+b) ? (?:aa)* a
$`)
var str = `aaaaaaaaaaaaaaaaaa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}