#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!\s*$)\s*(?!\s)([^#\n\[=]+?)\s*?(?>#.*?$|(?>=\s*$|=\s*?(?:#?|(".*?"|[^\s].*?)\s*?)(?:\s*#.*?$)*?$)?$)"
Local $sString = "[mysqld]" & @CRLF & _
"skip-grant-tables # k" & @CRLF & _
"bind-address=127.0.0.1" & @CRLF & _
" port = 3307 # test " & @CRLF & _
"basedir=C:\Program Files (x86)\MySQL\ " & @CRLF & _
"datadir=C:\Program Files (x86)\MySQL\data\" & @CRLF & _
"" & @CRLF & _
"default-storage-engine=INNODB " & @CRLF & _
"" & @CRLF & _
"sql-mode= " STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,test NO_ENGINE_SUBSTITUTION" #test" & @CRLF & _
"" & @CRLF & _
"max_connections=1000" & @CRLF & _
"" & @CRLF & _
"tmp_table_size=1G" & @CRLF & _
"max_heap_table_size=1G" & @CRLF & _
"join_buffer_size=1M " & @CRLF & _
"query_cache_size =50M" & @CRLF & _
"query_cache_limit=50M" & @CRLF & _
"max_allowed_packet = 104857600" & @CRLF & _
"port =" & @CRLF & _
"" & @CRLF & _
" = fh" & @CRLF & _
"thread_cache_size=8" & @CRLF & _
"" & @CRLF & _
"#*** MyISAM Specific options" & @CRLF & _
"" & @CRLF & _
"myisam_max_sort_file_size=100G" & @CRLF & _
"myisam_sort_buffer_size=35M" & @CRLF & _
"key_buffer_size=25M" & @CRLF & _
"read_buffer_size=64K" & @CRLF & _
"read_rnd_buffer_size=256K" & @CRLF & _
"sort_buffer_size=256K" & @CRLF & _
"" & @CRLF & _
"#*** INNODB Specific options ***" & @CRLF & _
"" & @CRLF & _
"innodb_flush_log_at_trx_commit=0" & @CRLF & _
"innodb_log_buffer_size=50M" & @CRLF & _
"innodb_buffer_pool_size=1000M" & @CRLF & _
"innodb_log_file_size=300M" & @CRLF & _
"innodb_thread_concurrency=8" & @CRLF & _
"innodb_flush_method=normal" & @CRLF & _
"innodb_autoinc_lock_mode=0 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"test=0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")