#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "! Global keywords\n\n(.*?)(?=\n\s*\n)"
Local $sString = "" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"! Generated with OLGA version 2017.2.0" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"! Global keywords" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"OPTIONS FLOWMODEL=OLGAHD" & @CRLF & _
"CASE AUTHOR=Schlumberger, PROJECT=OLGA, TITLE="Basic Case"" & @CRLF & _
"FILES PVTFILE=./3phase.tab" & @CRLF & _
"INTEGRATION ENDTIME=60 M, MAXDT=5 s, MINDT=0.01 s, STARTTIME=0 s, DTSTART=0.01 s" & @CRLF & _
"OUTPUT DTOUT=1 h" & @CRLF & _
"PROFILE DTPLOT=5 M" & @CRLF & _
"TREND DTPLOT=15 s" & @CRLF & _
"TRENDDATA VARIABLE=(VOLGBL, HT, GTSOUR)" & @CRLF & _
"" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"! Library keywords" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"WALL LABEL="WALL-1", THICKNESS=(0.009, 0.02, 0.02) m, MATERIAL=("MATER-1", "MATER-2", \" & @CRLF & _
" "MATER-2")" & @CRLF & _
"WALL LABEL="WALL-2", THICKNESS=(0.0075, 0.02, 0.02) m, MATERIAL=("MATER-1", "MATER-2", \" & @CRLF & _
" "MATER-2")" & @CRLF & _
"MATERIAL LABEL="MATER-1", CAPACITY=500 J/kg-C, CONDUCTIVITY=50 W/m-C, DENSITY=7850 kg/m3" & @CRLF & _
"MATERIAL LABEL="MATER-2", CAPACITY=880 J/kg-C, CONDUCTIVITY=1 W/m-C, DENSITY=2500 kg/m3" & @CRLF & _
"" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"! Network Component" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"NETWORKCOMPONENT TYPE=FLOWPATH, TAG=FP_PIPELINE" & @CRLF & _
" PARAMETERS LABEL=PIPELINE" & @CRLF & _
" GEOMETRY LABEL="GEOM-1"" & @CRLF & _
" PIPE ROUGHNESS=5E-05 m, LABEL="PIPE-1", WALL="WALL-1", NSEGMENT=10, LENGTH=400 m, \" & @CRLF & _
" ELEVATION=10 m, DIAMETER=0.12 m" & @CRLF & _
" BRANCH FLUID=Fluid1" & @CRLF & _
" HEATTRANSFER LABEL="HEATTRANS-1", TAMBIENT=6 C, HAMBIENT=6.5 W/M2-C" & @CRLF & _
" SOURCE LABEL="SOURCE-1", TIME=(0, 10, 20, 30, 40) M, PIPE="PIPE-1", SECTION=1, \" & @CRLF & _
" TEMPERATURE=(62, 62, 62, 62, 62) C, MASSFLOW=(18, 18, 9, 9, 18) KG/S" & @CRLF & _
" TRENDDATA PIPE="PIPE-1", SECTION=1, VARIABLE=(HOL, HOLWT, ID, PT, Q2, TM, TU)" & @CRLF & _
" TRENDDATA VARIABLE=(OILC, WATC, GASC, OILCFR, WATCFR, GASCFR)" & @CRLF & _
" PROFILEDATA VARIABLE=(HOL, PT, TM, QLT, QG, Q2, ID, QLTWT)" & @CRLF & _
" SERVERDATA PIPE="PIPE-1", SECTION=1, VARIABLE=(HOL, HOLWT, PT, TM)" & @CRLF & _
" SERVERDATA VARIABLE=(HOL, HOLWT, PT, TM)" & @CRLF & _
" SERVERDATA VARIABLE=(QLT, QG, QLTWT, ID)" & @CRLF & _
" TRENDDATA PIPE="PIPE-1", SECTION=11, VARIABLE=(QT, QG, QLT, QLTHL, QLTWT, QGST, \" & @CRLF & _
" QOST, QWTST, GT, GG, GL)" & @CRLF & _
"ENDNETWORKCOMPONENT" & @CRLF & _
"" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"! Network Component" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"NETWORKCOMPONENT TYPE=NODE, TAG=NODE_INLET" & @CRLF & _
" PARAMETERS LABEL=INLET, TYPE=CLOSED" & @CRLF & _
"ENDNETWORKCOMPONENT" & @CRLF & _
"" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"! Network Component" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"NETWORKCOMPONENT TYPE=NODE, TAG=NODE_OUTLET" & @CRLF & _
" PARAMETERS LABEL=OUTLET, TYPE=PRESSURE, TEMPERATURE=22 C, PRESSURE=5000000 Pa, \" & @CRLF & _
" FLUID=Fluid1" & @CRLF & _
"ENDNETWORKCOMPONENT" & @CRLF & _
"" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"! Connections" & @CRLF & _
"!**************************************************************************************" & @CRLF & _
"CONNECTION TERMINALS = (FP_PIPELINE INLET, NODE_INLET FLOWTERM_1)" & @CRLF & _
"CONNECTION TERMINALS = (FP_PIPELINE OUTLET, NODE_OUTLET FLOWTERM_1)" & @CRLF & _
"" & @CRLF & _
"ENDCASE" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)