using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(if)\s+([^\]]*+)\]
((?>(?!\[(?:end)?if\b).|(?R))*)
\[endif\]";
string input = @"[if coooondition1] aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa [if condition2] bb [endif] [endif]";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}