package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9_]{1,16}$`)
var str = `HighFructoseCorn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}