#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<REMITReceipt(.|\n)*?<errorCount>0(.|\n)*?\/REMITReceipt>"
Local $sString = "" & @CRLF & _
" " & @CRLF & _
"=== Receipt_20150922_REMITTable1_V1_A0000668C.SI_1.xml.asc" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<REMITReceipt xmlns="http://www.acer.europa.eu/REMIT/REMITReceiptSchema_V1.xsd">" & @CRLF & _
" <receiptTimestamp>2015-09-22T14:25:04.009+02:00</receiptTimestamp>" & @CRLF & _
" <rrmId>" & @CRLF & _
" <acer>A0000668C.SI</acer>" & @CRLF & _
" </rrmId>" & @CRLF & _
" <receiptType>validation</receiptType>" & @CRLF & _
" <validationReceipt>" & @CRLF & _
" <reportedFilename>20150922_REMITTable1_V1_A0000668C.SI_1.xml.asc.pgp</reportedFilename>" & @CRLF & _
" <reportedFileChecksum>6445BEC781F4000C7F16F8685103B2D2D4DC500B</reportedFileChecksum>" & @CRLF & _
" <errorCount>0</errorCount>" & @CRLF & _
" <globalReceiptItem>" & @CRLF & _
" <logicalRecordIdentifier>FWG_L_Sep_15</logicalRecordIdentifier>" & @CRLF & _
" <logicalRecordType>CONTRACT</logicalRecordType>" & @CRLF & _
" <status>Accepted</status>" & @CRLF & _
" </globalReceiptItem>" & @CRLF & _
" </validationReceipt>" & @CRLF & _
"</REMITReceipt>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"=== Receipt_20150922_REMITTable1_V1_A0000668C.SI_10.xml.asc " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<REMITReceipt xmlns="http://www.acer.europa.eu/REMIT/REMITReceiptSchema_V1.xsd">" & @CRLF & _
" <receiptTimestamp>2015-09-24T09:35:07.530+02:00</receiptTimestamp>" & @CRLF & _
" <rrmId>" & @CRLF & _
" <acer>A0000668C.SI</acer>" & @CRLF & _
" </rrmId>" & @CRLF & _
" <receiptType>validation</receiptType>" & @CRLF & _
" <validationReceipt>" & @CRLF & _
" <reportedFilename>20150922_REMITTable1_V1_A0000668C.SI_10.xml.asc.pgp</reportedFilename>" & @CRLF & _
" <reportedFileChecksum>13F5F5D46DFC659380AD1A7982CC2F05E7E66D5E</reportedFileChecksum>" & @CRLF & _
" <errorCount>0</errorCount>" & @CRLF & _
" <globalReceiptItem>" & @CRLF & _
" <logicalRecordIdentifier>4</logicalRecordIdentifier>" & @CRLF & _
" <logicalRecordType>TRADE</logicalRecordType>" & @CRLF & _
" <status>Accepted</status>" & @CRLF & _
" <logicalRecordTimestamp>2015-07-14T13:12:16.223+02:00</logicalRecordTimestamp>" & @CRLF & _
" <logicalRecordChecksum>F6A488630A39390BE48420AFFD40ED7C82D20309</logicalRecordChecksum>" & @CRLF & _
" </globalReceiptItem>" & @CRLF & _
" <globalReceiptItem>" & @CRLF & _
" <logicalRecordIdentifier>3</logicalRecordIdentifier>" & @CRLF & _
" <logicalRecordType>TRADE</logicalRecordType>" & @CRLF & _
" <status>Accepted</status>" & @CRLF & _
" <logicalRecordTimestamp>2015-07-14T13:12:16.223+02:00</logicalRecordTimestamp>" & @CRLF & _
" <logicalRecordChecksum>026F539B94346186078BA906DE2F5A9F8B3E7F6E</logicalRecordChecksum>" & @CRLF & _
" </globalReceiptItem>" & @CRLF & _
" <globalReceiptItem>" & @CRLF & _
" <logicalRecordIdentifier>2</logicalRecordIdentifier>" & @CRLF & _
" <logicalRecordType>TRADE</logicalRecordType>" & @CRLF & _
" <status>Accepted</status>" & @CRLF & _
" <logicalRecordTimestamp>2015-07-14T08:46:40.513+02:00</logicalRecordTimestamp>" & @CRLF & _
" <logicalRecordChecksum>0F8253A2A3C55520E4D63959E77286CA1E95622B</logicalRecordChecksum>" & @CRLF & _
" </globalReceiptItem>" & @CRLF & _
" <globalReceiptItem>" & @CRLF & _
" <logicalRecordIdentifier>1</logicalRecordIdentifier>" & @CRLF & _
" <logicalRecordType>TRADE</logicalRecordType>" & @CRLF & _
" <status>Accepted</status>" & @CRLF & _
" <logicalRecordTimestamp>2015-07-14T08:46:37.223+02:00</logicalRecordTimestamp>" & @CRLF & _
" <logicalRecordChecksum>198B018687C9D97CD3EECFBACA7EA9F196B5B80F</logicalRecordChecksum>" & @CRLF & _
" </globalReceiptItem>" & @CRLF & _
" </validationReceipt>" & @CRLF & _
"</REMITReceipt>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"=!== Receipt_20150922_REMITTable1_V1_A0000668C.SI_100.xml.asc "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")