#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)CREATE( (LOCAL )?(?P<temporal>TEMPORARY|TEMP))? TABLE( IF NOT EXISTS)? (?P<schema_name>[{ }\w_]+).(?P<table_name>[{ }\w_]+) ?\((?P<columns>([\w _](\(\d+\))?,?)+)\)( DISTSTYLE (?P<dist_style>(EVEN|KEY|ALL)))?( DISTKEY \((?P<dist_key>[\w_]+)\))?( (?P<sort_key_type>(COMPOUND|INTERLEAVED) )?SORTKEY \((?P<sort_keys>([\w _,]+))\))?"
Local $sString = "-- TEST 2 WITH COLUMNS" & @CRLF & _
"CREATE( (LOCAL )?(?P<temporal>TEMPORARY|TEMP))? TABLE( IF NOT EXISTS)? (?P<schema_name>[{ }\w_]+).(?P<table_name>[{ }\w_]+) \( (?P<columns>([\w _](\(\d+\))?,?)+) \)" & @CRLF & _
"" & @CRLF & _
"-- COLUMNS" & @CRLF & _
"\( ([\w _](\(\d+\))?,?)+ \)" & @CRLF & _
"" & @CRLF & _
"-- COLUMNA" & @CRLF & _
"(?P<column>([\w _](\(\d+\))?)+)" & @CRLF & _
"" & @CRLF & _
"-- TABLE ATTRIBUTE" & @CRLF & _
"(DISTSTYLE (?P<dist_style>(EVEN|KEY|ALL)))|(DISTKEY\((?P<dist_key>[\w_]+)\))|((?P<sort_key_type>(COMPOUND|INTERLEAVED) )?SORTKEY \((?P<sort_keys>([\w _,]+))\))" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CREATE TABLE {{schema}}.ad_params (er_id_site INTEGER ENCODE DELTA, er_id_ad VARCHAR(256) ENCODE LZO, ad_param_key VARCHAR(256), ad_param_value VARCHAR(256), id_ad_param_value VARCHAR(256), dt_audit_insert TIMESTAMP WITHOUT TIME ZONE ENCODE LZO, dt_audit_update TIMESTAMP WITHOUT TIME ZONE ENCODE LZO, dt_audit_analysis TIMESTAMP WITHOUT TIME ZONE ENCODE LZO) DISTKEY (er_id_ad) INTERLEAVED SORTKEY (er_id_site, er_id_ad, ad_param_key, id_ad_param_value)" & @CRLF & _
"" & @CRLF & _
"DROP TABLE IF EXISTS {{ dm_site_schema }}.ad_cohort;" & @CRLF & _
"" & @CRLF & _
"---------------------------------------" & @CRLF & _
"CREATE TABLE {{staging_site_schema}}.ads (ad_id INTEGER NOT NULL ENCODE DELTA32k, list_id VARCHAR(32) ENCODE LZO, list_time VARCHAR(32) ENCODE LZO, status VARCHAR(32), name VARCHAR(128), region INTEGER, category INTEGER, user_id INTEGER, phone_hidden BOOL, no_salesmen BOOL, company_ad BOOL, subject VARCHAR(256) ENCODE LZO, body VARCHAR(65535) ENCODE LZO, price VARCHAR(16) ENCODE LZO, orig_list_time VARCHAR(32) ENCODE LZO, old_price VARCHAR(16) ENCODE LZO, modified_at VARCHAR(32) ENCODE LZO, lang VARCHAR(32), type VARCHAR(32), account_id INTEGER) DISTKEY(ad_id)" & @CRLF & _
"---------------------------------------" & @CRLF & _
"DROP TABLE IF EXISTS {{staging_site_schema}}.state_params" & @CRLF & _
"---------------------------------------" & @CRLF & _
"CREATE TABLE {{staging_site_schema}}.state_params (ad_id INTEGER encode raw, action_id INTEGER encode raw, state_id INT4 encode raw, name VARCHAR(20) encode raw, value VARCHAR(65535) encode raw) DISTKEY(ad_id)" & @CRLF & _
"---------------------------------------" & @CRLF & _
"DROP TABLE IF EXISTS {{staging_site_schema}}.users" & @CRLF & _
"---------------------------------------" & @CRLF & _
"CREATE TABLE {{staging_site_schema}}.users (user_id INTEGER ENCODE DELTA, uid INTEGER ENCODE DELTA, email VARCHAR(124) ENCODE LZO, account INTEGER ENCODE LZO, paid_total INTEGER ENCODE LZO) DISTKEY(user_id)" & @CRLF & _
"---------------------------------------" & @CRLF & _
"---------------------------------------" & @CRLF & _
"CREATE TABLE {{ staging_site_schema }}.ad_params ( ad_id INTEGER NOT NULL ENCODE DELTA32k, name VARCHAR(32), value VARCHAR(1024)) DISTKEY(ad_id)" & @CRLF & _
"" & @CRLF & _
"CREATE TABLE {{ staging_site_schema }}.ad_params ( ad_id INTEGER NOT NULL ENCODE DELTA32k, name VARCHAR(32), value VARCHAR(1024)) " & @CRLF & _
"CREATE TABLE {{ staging_site_schema }}.ad_params ( ad_id INTEGER NOT NULL ENCODE DELTA32k, name VARCHAR(32), value VARCHAR(1024)) DISTSTYLE ALL INTERLEAVED SORTKEY (dt_creation, dt_posting, er_id_region, er_id_site_location);" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CREATE [ [LOCAL ] { TEMPORARY | TEMP } ] TABLE " & @CRLF & _
"[ IF NOT EXISTS ] table_name" & @CRLF & _
"( { column_name data_type [column_attributes] [ column_constraints ] " & @CRLF & _
" | table_constraints" & @CRLF & _
" | LIKE parent_table [ { INCLUDING | EXCLUDING } DEFAULTS ] } " & @CRLF & _
" [, ... ] )" & @CRLF & _
"[ BACKUP { YES | NO } ]" & @CRLF & _
"[table_attribute]" & @CRLF & _
"" & @CRLF & _
"and table_attributes are:" & @CRLF & _
" [ DISTSTYLE { EVEN | KEY | ALL } ] " & @CRLF & _
" [ DISTKEY ( column_name ) ]" & @CRLF & _
" [ [COMPOUND | INTERLEAVED ] SORTKEY ( column_name [, ...] ) ]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")