$re = '/\s*[+*)(](?![^[]*])\s*/';
$str = '.N.TEST[INT1+2] + ON[INT1] * ON[INT2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);