# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?([0-9]+-[a-zA-Z]{2,}-[0-9]+).*"
test_str = ("\"NE-390-SM-04\"\n"
" --> \"390-SM-04\"\n\n"
"\"90055-SL-01-J\"\n"
" --> \"90055-SL-01\"\n\n"
"\"NE-1478-SL-02\"\n"
" --> \"1478-SL-02\"\n\n"
"\"87007-QM-01-J\"\n"
" --> \"87007-QM-01\"\n\n"
"\"NE-9315-BM-01-A\"\n"
" --> \"9315-BM-01\"\n\n"
"\"3121-SP-01\"\n"
" --> \"3121-SP-01\"\n\n"
"\"1639-YL-01\"\n"
" --> \"1639-YL-01\"\n\n"
"\"NE-9922-WM-01-J\"\n"
" --> \"9922-WM-01\"\n\n"
"\"ND-2498-YL-01\"\n"
" --> \"2498-YL-01\"\n\n"
"\"C-4008-PP-03-J\"\n"
" --> \"4008-PP-03\"\n\n"
"\"876-C-4008-PP-03-J-234\"\n"
" --> \"4008-PP-03\"")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.