#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)import(?:["'\s]*([\w*{}\n\r\t, ]+)from\s*)?["'\s].*([@\w/_-]+)["'\s].*;$"
Local $sString = "import {" & @CRLF & _
" Component" & @CRLF & _
"} from '@angular2/core';" & @CRLF & _
"import defaultMember from "module-name";" & @CRLF & _
"import * as name from "module-name ";" & @CRLF & _
"import { member } from " module-name";" & @CRLF & _
"import { member as alias } from "module-name";" & @CRLF & _
"import { member1 , member2 } from "module-name";" & @CRLF & _
"import { member1 , member2 as alias2 , member3 as alias3 } from "module-name";" & @CRLF & _
"import defaultMember, { member, member } from "module-name";" & @CRLF & _
"import defaultMember, * as name from "module-name";" & @CRLF & _
"import "module-name";" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" *Add all needed dependency to this module" & @CRLF & _
" *app requires those import modules to function" & @CRLF & _
"**/" & @CRLF & _
"" & @CRLF & _
"let modules = [];" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")