package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*([\W]+)\W`)
var str = `aaaaaas#aa##aa`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}