import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\W\\dA-Z && (I|X|L|V|\\.)])\\1{2}";
final String string = "<H1><h><key1>SaravARi</key1><key2>*SaravARi</key2></h><body><gram n=\"\"></gram>m. <divm type=\"e\" n=\"1\">1)</divm> <i>Pfeilspitze.</i> <divm type=\"e\" n=\"2\">2)</divm> <i>Verfertiger von Pfeilen.</i> <divm type=\"e\" n=\"3\">3)</divm> <i>Fusssoldat.</i> <divm type=\"e\" n=\"4\">4)</divm> = <s>papizWa</s> ; <noti>wohl fehlerhaft für</noti> <s>padAti</s>. PW110624</body><tail><L>110623</L><pc>6211-2</pc></tail></H1>\n"
+ "<H1><h><key1>SaravARi</key1><key2>*SaravARi</key2></h><body><gram n=\"\"></gram>m. <divm type=\"e\" n=\"1\">1)</divm> <i>Pfeilspitze.</i> <divm type=\"e\" n=\"2\">2)</divm> <i>Verfertiger von Pfeilen.</i> <divm type=\"e\" n=\"3\">3)</divm> <i>Dusssoldat.</i> <divm type=\"e\" n=\"4\">4)</divm> = <s>papizWa</s> ; <noti>wohl fehlerhaft für</noti> <s>padAti</s>. PW110624</body><tail><L>110623</L><pc>6211-2</pc></tail></H1>\n"
+ "<H1><h><key1>SaSapada</key1><key2>SaSapada</key2></h><body><gram n=\"\"></gram>n. <i>Hasenfussstapfen.</i> <noti>so v.a.</noti> <i>worüber man leicht hinwegkommt</i> <ls>HARSHAK4.181,6.</ls> PW110959</body><tail><L>110958</L><pc>6215-2</pc></tail></H1>\n"
+ "<H1><h><key1>svatas</key1><key2>svatas</key2></h><body><gram n=\"\"></gram>Adv. <divm type=\"e\" n=\"1\">1)</divm> = <s>svasmAt</s> <gram n=\"\"></gram>Adj. <noti>und</noti> <gram n=\"\"></gram>Subst. <gram n=\"\"></gram>m. <s>svatoM 'SAt</s> <i>vom eigenen Theile.</i> <s>tadrakzerapacAraM tvaM</s> [Page7.232-2] <s>svato vA parato 'pi vA</s> <noti>so v.a.</noti> <i>hüte dich selbst und Andere vor einem Vergehen.</i> <divm type=\"e\" n=\"2\">2)</divm> <i>aus sich (aus mir selbst , aus dir selbst</i> <noti>u.s.w.)</noti> , <i>von sich aus , von selbst</i> , <noti>d.i.</noti> <i>ohne Hinzutreten eines Andern.</i> <divm type=\"e\" n=\"3\">3)</divm> <i>von selbst</i> , <noti>so v.a.</noti> <i>naturgemäss.</i> <divm type=\"e\" n=\"4\">4)</divm> <i>vom Eigenen , vom eigenen Vermögen.</i> <noti>--</noti> <s>ca svataH</s> <ls>PAN4K4AT.III,96</ls> <noti>schlechte Lesart für</noti> <s>SASvataH</s>. PW132059</body><tail><L>132058</L><pc>7232-1</pc></tail></H1>\n"
+ "<H1><h><key1>aNkAsya</key1><key2>aNkAsya</key2></h><body><gram n=\"\"></gram>n. <i>Diejenige Schlussscene eines Actes , welche , indem sie eine Unterbrechung herbeiführt.</i> PW890</body><tail><L>890</L><pc>1011-1</pc></tail></H1>\n"
+ "<H1><h><key1>susaMdIpta</key1><key2>susaMdIpta</key2></h><body><gram n=\"\"></gram>Adj. <i>schön flammend</i> <ls>PAN4K4AT.</ls> <noti>VIII , 167.</noti> PW128334</body><tail><L>128333</L><pc>7172-2</pc></tail></H1>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}