$re = '/\s+/';
$str = 'This is an example so it becomes';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;