re = /(?=.*?(love|like).*?(programming))/
str = 'I lov love programming love a lot! love'
# Print the match result
str.match(re) do |match|
puts match.to_s
end