re = /\bstop[a-zA-Z]*/
str = 'stop
hey stop select random
not the start of line stopping but the end
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end