package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bstop[a-zA-Z]*`)
var str = `stop
stopping with line
stop and so on
hey stop select random
not the start of line stopping but the end
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}