# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\b)\w([\w\.\-_0-9])*(@| at )[\w0-9][\w\-_0-9]*((\.| DOT )[\w\-_0-9]+)+(?=\b)"
test_str = ("test@email.com\n"
"test-user@email.com\n"
"test.user@email.com\n"
"33test33@email.com\n"
"test99user-_22@email.com\n"
"test@e.mail\n"
"test@g.mail\n"
"test AT email.com\n"
"test AT email DOT com\n"
"test AT email dot com\n"
"test at email.com\n"
"test@email DOT com\n"
"this is not an email @twitterUser\n"
"this is just an an string el@\n\n\n\n"
" Valid\n"
"-------\n"
"first.last@iana.org\n"
"1234567890123456789012345678901234567890123456789012345678901234@iana.org\n"
"x@x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x23456789.x2\n"
"1234567890123456789012345678901234567890123456789012345678@12345678901234567890123456789012345678901234567890123456789.12345678901234567890123456789012345678901234567890123456789.123456789012345678901234567890123456789012345678901234567890123.iana.org\n"
"user+mailbox@iana.org\n"
"customer/department@iana.org \n"
"customer/department=shipping@iana.org\n"
"cal(woo(yay)hoopla)@iamcal.com\n"
"cal(foo\\@bar)@iamcal.com\n"
"cal(foo\\)bar)@iamcal.com\n"
"first(Welcome to the (\"wonderful\" (!)) world of email)@iana.org\n"
"pete(his account)@silly.test(his host)\n"
"c@(Chris's host.)public.example\n\n"
" Invalid\n"
"---------\n"
"first@...........com\n"
"first.last@sub.do,com\n"
"first\\@last@iana.org\n"
"first.last\n"
".first.last@iana.org\n"
"first.last.@iana.org\n"
"\"first\"last\"@iana.org\n"
"\"\"\"@iana.org\n"
"first\\\\@last@iana.org\n"
"Doug\\ \\\"Ace\\\"\\ Lovell@iana.org\n"
"()[]\\;:,><@iana.org\n"
"test@.\n"
"test@[123.123.123.123\n"
"test@123.123.123.123]")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.