re = /(?=.*[A-Z])(?=.*[0-9])(?!.\n)(?!.*\s)(?=.*[!$#+@%&]).{8,}/
str = 'aikh3!kc
aiKH3ckc
aiKHhckc
aiKH33 !kc
aiKH3!kdsc'
# Print the match result
str.match(re) do |match|
puts match.to_s
end