$re = '/(\b\w+(?: \w+\b)+)/';
$str = 'string = \' a title of foo b \'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);