# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(@media[^{]+\{(?:([^{]+?\{[^}]*?\})*|(?1))*\})"
test_str = (" @media only screen {\n"
" p {\n"
" color:red;\n"
" }\n"
" }\n"
" @media only screen and (max-width: 596px) {\n"
" p {\n"
" color:blue;\n"
" }\n"
" }\n"
" @media only screen {\n"
" \n"
" }\n"
" img {\n"
" display: block;\n"
" }\n"
" @media only screen and (max-width: 240px) {\n"
" p {\n"
" color:green;\n"
" }\n"
" }\n"
" p {\n"
" font-weight: normal;\n"
" }\n")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.