re = /.*(?<=email&jobId\=)(\d+)(?=&distance).*/
str = '/visitor/browseJobDetails.do?comeFrom=email&jobId=3931052&distance=18&rx=email_NJNY%7CProvider_Featured%7Cjobtitle%7C91942%7CCHILDCARE`'
# Print the match result
str.match(re) do |match|
puts match.to_s
end