$re = '/^[a-zA-Z.-]+@[a-zA-Z]{1,5}(?:\.[a-zA-Z]{1,5}){0,2}\.[a-zA-Z]{2,3}$/m';
$str = 'user@aaa.bb.cccc.dd
user@aaa.bb.cccc.dd.ee
user@aaa.bv.cccc
user@aaaa.bbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);