$re = '/\bi2\d{3}-\d{1,3}\b/';
$str = 'i2123-1
i2121-20
i2111-331
i2111
i21111
i2111-1141
i2123-1
1i2121-20
ai2111-331';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);