const regex = /\bBegin(\d+)\b([\S\s]*)\bEnd\1\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bBegin(\\d+)\\b([\\S\\s]*)\\bEnd\\1\\b', 'gm')
const str = `Begin10
Match THIS keyword and ANOTHER
End15
End10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}