re = /^(?:(-?[1-8]?\d(?:\.\d{1,18})?|90(?:\.0{1,18})?),(-?(?:1[0-7]|[1-9])?\d(?:\.\d{1,18})?|180(?:\.0{1,18})?))(?:\|(?:(-?[1-8]?\d(?:\.\d{1,18})?|90(?:\.0{1,18})?),(-?(?:1[0-7]|[1-9])?\d(?:\.\d{1,18})?|180(?:\.0{1,18})?)))*$/
str = '-82.3,-13.34|-82.3,-13.34|-82.3,-13.34|-82.3,-13.34|-82.3,-13.34|-82.3,-13.34'
# Print the match result
str.match(re) do |match|
puts match.to_s
end