$re = '/width_(\d+\w+)/';
$str = 'width_100%
width_100px';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);