$re = '/(?P<Capture>pattern.*?sentence).*?\./m';
$str = 'Find the pattern when it is. In the same sentence. Find the pattern when it is in the same sentence.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);