import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<ip>.*?) (?P<remote_log_name>.*?) (?P<userid>.*?) \\[(?P<date>.*?)(?= ) (?P<timezone>.*?)\\] \\\"(?P<request_method>.*?) (?P<path>.*?)(?P<request_version> HTTP/.*)?\\\" (?P<status>.*?) (?P<length>.*?) \\\"(?P<referrer>.*?)\\\" \\\"(?P<user_agent>.*?)\\\" (?P<session_id>.*?) (?P<generation_time_micro>.*?) (?P<virtual_host>.*)";
final String string = "1.1.1.2 - - [11/Nov/2016:03:04:55 +0100] \"GET /\" 200 83 \"-\" \"-\" - 9221 1.1.1.1\n"
+ "127.0.0.1 - - [11/Nov/2016:14:24:21 +0100] \"GET /uno dos\" 404 298 \"-\" \"-\" - 400233 1.1.1.1\n"
+ "127.0.0.1 - - [11/Nov/2016:14:23:37 +0100] \"GET /uno dos HTTP/1.0\" 404 298 \"-\" \"-\" - 385111 1.1.1.1\n"
+ "1.1.1.1 - - [11/Nov/2016:00:00:11 +0100] \"GET /icc HTTP/1.1\" 302 - \"-\" \"XXX XXX XXX\" - 6160 11.1.1.1\n"
+ "1.1.1.1 - - [11/Nov/2016:00:00:11 +0100] \"GET /icc/ HTTP/1.1\" 302 - \"-\" \"XXX XXX XXX\" - 2981 1.1.1.1\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}