re = /(?<=\d)(?:[;,] ?| )(?=\d)/m
str = '3.14; 42.2
3.14;42.2
3.14, 42.2
3.14,42.2
3.14 42.2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end