$re = '/[^\d.]+|\d*(?:\.\d+)?/m';
$str = 'abc4.5efg2hij89k.9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);