package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^!?(m|[0-X])$`)
var str = `0`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}