#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[A-Za-z]_[A-Za-z]*|\d+)(?:,|$))+(?<!,)$"
Local $sString = "A_AAAAA,B_BBBBB,122334,D_DFDFDF" & @CRLF & _
"12345,123567,123456,A_BBBBB,C_DDDDD,1234567" & @CRLF & _
"" & @CRLF & _
"RR_RRR,12345" & @CRLF & _
"1_111,AVSFFF," & @CRLF & _
"A_SDDF,,123342" & @CRLF & _
"A_AAAAA,B_BBBBB,122334,D_DFDFDF,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")