re = /^(?:([0-9]*|\d+)(?:,|$))+(?<!,)$/m
str = 'A_AAAAA,B_BBBBB,122334,D_DFDFDF
12345,123567,123456,A_BBBBB,C_DDDDD,1234567
-1235,151,548,54,1
RR_RRR,12345
1_111,AVSFFF,
A_SDDF,,123342
A_AAAAA,B_BBBBB,122334,D_DFDFDF,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end