$re = '/^(?=.*[A-Z])(?=.*[a-z])(?=.*\d).{8,}$/';
$str = 'asdbS8lsd';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);