const regex = /({matrix}.*? \\)( .*?{matrix})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({matrix}.*? \\\\)( .*?{matrix})', 'gm')
const str = ` \\left(\\begin{matrix} \\sqrt[ 5 ]{ 6 \\phantom{\\tiny{!}}} \\ \\dfrac{ 55 }{ 66 } \\end{matrix}\\right)
`;
const subst = `$1\\$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);