package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\[[^][]*]|\s)+`)
var str = `[0:00:19] spk_0: yeah. I don't want to jump in to say`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}