$re = '/(?<=www)\-\w+(?=\.)/';
$str = 'www-test1.examples.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);