import re
regex = re.compile(r"^[a-zA-Z][a-zA-Z0-9_+.-]*@[a-zA-Z.-]+\.(?:edu7?|com|org)$", flags=re.MULTILINE)
test_str = (" somebody@gmail.com\n"
"somebody@gmail.com\n"
"5somebody@gmail.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")