$re = '/^3[Aa-Zz]/m';
$str = 'Oct 8 22:00:00 dev-db crond[18340]: (root) CMD (/bin/sh /home/root/bin/system_check &)
Oct 8 23:00:00 dev-db crond[20348]: (oracle) CMD (/bin/sh /home/oracle/bin/cleanup.sh &)
Oct 8 23:59:00 dev-db crond[20399]: (john) CMD (/bin/sh /home/john/bin/backup.sh &)';
$subst = "\1 -> \3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;