re = /(?:'[^']*'|"[^"]*")(*SKIP)(*FAIL)|;/
str = 'print \'d;dd\'; print "word; word"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end